Print Jobs Getting Stuck
Incident Report for MBI Systems Status
Resolved
Everything is functional again. Please report any further issues to ITS.
Posted May 01, 2024 - 06:46 CDT
Investigating
We have received several reports on print jobs being stuck and not printing. We are currently investigating this and the impact it has. If you have printer problems please report them to the ITS Support Center.
Posted Apr 30, 2024 - 14:24 CDT
This incident affected: Infrastructure/Networking (Campus Printing).